Download Huawei P9 Lite Stock Firmware (All Variants)

This is a collection of Huawei P9 Lite stock ROMs / firmware for all variants. Try not to use any of the firmware package on this page to flash any other device that does fit the P9 Lite variants listed here. It will cause the device to brick.

Learn how to root Huawei P9 Lite without stress

Download the firmware package from below and do not forget to post in comments section if your P9 Lite variant stock ROM is not listed here.

B100

B120

B123

B130
  • VNS-L31C432B130 (Dual-SIM) – Download

B161

Middle East and Africa

How to flash Huawei P9 Lite Stock Firmware

Click here and follow the instructions in the post to flash any of the firmware in this post on your Huawei P9 Lite variant.

34 Comments

  1. Can i use this firmware to fix my bootlooped p9 lite nougat.?? Please if someone knows how, I badly need a help. 🙁 🙁

    • Hi Archer_15!

      Of course! Flashing this firmware will fix your device’ bootloop.

      But, have you tried performing a factory reset to see if it fixes?

  2. Hi
    Please help. I have flashed VNS-L22C185B140 for my L22 variant. It was successful, but now the phone will not boot past the logo. It shows the logo and then goes dark. It does not turn off as there is a slight glow to the dark screen. I have tried flashing a lower version ( 130) but it stops at 5% and says, vision incompatibility error.

  3. Hi great ! My phone is l31 b120 Middle Africa, which rom can I use for dual sim?

    Out of interest, so the L31 is model and b120 is latest firmware? Meaning if I have b120 I can flash the b150 as long as it l31?

    Thanks in advance

    • Bxxx indicates the firmware version/build, you’re correct.

      To know the firmware that is suitable for your phone, check in Settings > About Device.

  4. Please help. I have flashed VNS-L21C185B140 for my L21 variant. It was successful, but now the phone will not boot past the logo. It shows the logo and then goes dark. It does not turn off as there is a slight glow to the dark screen. I have tried flashing a lower version and says, vision incompatibility
    .

  5. Thanks @leakite, that was helpful I know need to find if Middle East and Africa roms include South Africa,

    just to confirm, my rom is VNS-L31c16B120, so I can use the VNS-L31C185B150?
    Thank you so much.

    • Hi Arthur. Did you come right with an update? I’m also on the same VNS as you, also South Africa with no update yet. Seems like we will never get the update for OTA. What’s your status?

  6. If your device firmware build is not yet available, please be patient….we’re doing our best to make them all available once it’s within our reach.

Leave a Comment

Your email address will not be published. Required fields are marked *

It is main inner container footer text